免费注册 | 用户登录 | 设为首页
站内搜索:
联系方式:QQ:613116699           邮箱:613116699@qq.com
股票
常见的涨停板选股公式
发布日期:2019-12-12  发布人:匿名  访问人数:224   收藏(0)

​​1、名称:涨停板站上布林线上轨选股公式

{上轨}UB:=BOLL+2*STD(CLOSE,20);

{中轨}BOLL:=MA(CLOSE,20);

{下轨}LB:=BOLL-2*STD(CLOSE,20);

XG:C/REF(C,1)>1.08 AND C>UB;

2、名称:16天涨停板

主要功能,收集16天内出现涨停板的个股

HHV((C-REF(C,1))/REF(C,1) >0.095,16);

3、名称:当天K线阳包阴

选出当天K线阳包阴(最好股价在低位)同时成交量较前一天放大的股票,

v/ref(v,1)>1.5 and ref(c,1)oand c>ref(o,1) and o<=ref(c,1);

4、前5日到前30日之间有过连续两个涨停的通达信选股公式选股

涨停:=(C-REF(C,1))*100/REF(C,1)>=9.90 AND C=H;

AA1:=EVERY(涨停,2);

XG1:=COUNT(AA1,30)>=1;

TT:=BARSLAST(AA1);

XG2:TT<=30 AND TT>=4 AND XG1;

5、财务指标选股公式

每股公积金大于2元; 2.每股未分配利润大于1元; 3.过去三年净资产收益率均在8%以上。并告诉我详细的使用方法,非常感谢!如不能编写公式,请告诉我用通达信选股怎么设置条件选过去三年净资产收益率均在8%以上。

A:=FINANCE(18)>2; B:=FINANCE(32)>1; D:=FINANCE(33)/FINANCE(34); A AND B AND D>0.08 AND REF(D,1)>0.08 AND REF(D,2)>0.08;

6、通达信软件选出最近20个交易日成交量创新低的所有股票?

MA1:LLV(VOL,20);

7、通达信虚拟量大3倍选股指标公式

XG:C>REF(C,1) AND C3;

8、涨停后回调到10日均线附近的选股公式

涨停:=C>REF(C,1)*1.09955 AND C=H;

M10:=MA(C,10);

最低:=IF(涨停,999999,L);

涨停后最低:=LLV(最低,BARSLAST(涨停)+1);

回调:REF(涨停后最低,1)>M10+0.02 AND CROSS(M10+0.02,L);

9、双涨停个股回调到10日线下再次出现5个点以上涨幅选股公式

ZT:=(C-REF(C,1))*100/REF(C,1)>=(10-1/REF(C,1))AND (C-REF(C,1))*100/REF(C,1)<=(10+1/REF(C,1)) AND H=C;

RZT:=REF(ZT,1);

SZT:=ZT AND RZT;

CSZT:=EXIST(SZT,10);

MA10:=MA(C,10);

CCX:=EXIST(C

GDC:=C/L>1.05 AND C>O;

X:CSZT AND CCX AND GDC;

10、涨停后回调到涨停二分之一的位置的选股公式

涨2停:=C>=INTPART(REF(C,1)*(1.0995)*100)/100 AND C=H ANDCURRBARSCOUNT<=20;

涨停中处:=REF((H+L)/2,BARSLAST(涨2停));

XG:CROSS(涨停中处*1.006,C) AND NOT(涨2停) AND C>涨停中处*0.995;

11、涨停后缩量回调下跌然后在涨停的指标选股公式就是那种N字形涨停的图形

n:最小1,最大100,缺省20

EZT:=HIGH>REF(CLOSE,1)*1.095; { 出现过涨停 }

EZTO:EXIST(EZT,N); { N天内存在过涨停 };

12、当天涨停过有打开的选股公式

XG:HIGH/REF(CLOSE,1)>1.095 AND CLOSE

在满足条件情况下,XG数值为1,否则为0

13、双响炮选股公式

k线形态前后一个涨停(或者大阳)中间小阴小阳窄幅震荡,股价浮动在两涨停之内

涨停:C>REF(C,1)*1.0996 AND C=H;

HH:=HHV(H,BARSLAST(涨停))REF(O,BARSLAST(涨停));

中间:=HH AND LL;

又涨停:REF(中间,1) AND 涨停;

14、通达信涨停双响炮选股公式

一次涨停至二次涨停之间的时间段内不破一次涨停最低价,一次与二次涨停时间间隔不超过30日。需要能识别选出30内有多次涨停的股票

TQ1:=C>=REF(C,1)*1.095 AND C>=H;

TQ:=BARSLAST(TQ1);

TG:=REF(L,(TQ));

TY:IF(L>=TG AND COUNT(TQ1,30)>=2 AND TQ<=30 ,1,0);

VV:=H/REF(C,1)>1.1 ANDC

COUNT(VV,60)>0;

15、股价在60日均线以上的选股公式

ZM:C>MA(C,60);

16、成交量5日 10日量均线走平或多头向上

MAV5:=MA(V,5);MAV10:=MA(V,10);

XG:MAV5>MAV10 AND MAV5>=REF(MAV5,1) AND MAV10>=REF(MAV10,1) ANDCROSS(MAV5,MAV10);

(已测试通过)

17、5.10.20日均线在最近5日内一直存在开盘价大于收盘价

MCO1:=(REF(MA(C,4),1)*4+O)/5;

MCO2:=(REF(MA(C,9),1)*9+O)/10;

MCO3:=(REF(MA(C,19),1)*19+O)/20;

MC1:=MA(C,5);

MC2:=MA(C,10);

MC3:=MA(C,20);

开盘价大:=MCO1>MC1 AND MCO2>MC2 AND MCO3>MC3 ;

一直存在:EVERY(开盘价大,5);

18、通达信30天以来最大成交量那天为阳K线的选股

var1:=close>open;

var2:=hhv(vol,30);

var3:=vol;

var4:=var2=var3;

var1 and var4zm:

19、条件VOL5均量线大于10线均量线

A1:=MA(VOL,5);

A2:=MA(VOL,10);

XG:A1>=A2;

20、个股最近3个K线周期内,出现成交量创此前120个K线周期内新低的情况

zm:count(v=llv(v,120),3)>=1;

21、MACD。KDJ的低位金叉通达信选股公式

{KDJ低位金叉选股}

XG:CROSS("KDJ.J","KDJ.K") AND "KDJ.J"<=20;

{MACD低位金叉选股}

XG:CROSS("MACD.DIF","MACD.DEA") AND "MACD.DIF"<-0.2;

22、通达信软件的MACD和KDJ同时金叉共振的选股公式

CROSS("MACD.DIF","MACD.DEA") ANDCROSS("KDJ.K","KDJ.D");

23、通达信选股公式 kdj指标在15值以下金叉

XG:CROSS(KDJ.J,KDJ.K) AND KDJ.J<15 ANDKDJ.K<15;

24、通达信KDJ的J低于10的选股公式

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

K:=SMA(RSV,M1,1);

D:=SMA(K,M2,1);

J:3*K-2*D<10;

25、5.10.20日均线多头且成交量小于20万且当日涨幅大于百分之五选股公式

ma(c,5)>ma(c,10) and ma(c,10)>ma(c,20) and v<200000 andc>ref(c,1)*10.5;

26、所有历史新高选股公式

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;

主力:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF

(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF

(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;

选股:主力=HHV(主力,0); 

a:主力=hhv(主力,0);

括号内的0天可以按需求修改。.}

27、通达信多头买入选股指标公式

G1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));

G2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));

G3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));

G4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));

A:=BARSLAST(CROSS(30,G1))<2 AND BARSLAST(CROSS(G1,50))<2;

B:=BARSLAST(CROSS(G4,G1))<2 AND G1>G4;

E:=G1>60 AND G4>70;

多头买入:A AND B AND E;

28、通达信均线弧度选股指标公式

N:=5;

a:=ma(c,n);

b:=intpart((a/ref(a,1)-1)*100);

tj1:=ref(b,1)=2 and b=4;

tj2:=ref(b,1)=3 and b=5;

tj1 or tj2;

29、通达信资金异动选股指标公式

N:=5;

VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

主动买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE

主动卖盘:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE资金异动:=VOL/MA(VOL,55)*100,COLORYELLOW;

SQX:=(C-MA(CLOSE,7))*100;

DIFF:=EMA(MA(SQX,3),1)*1000,COLOR00FFFF;

DEA:=EMA(DIFF,3)*1,COLOR00FF00;

LONGCROSS(DIFF,DEA,N);

30、通达信最近20个交易日成交量创新低的所有股票

MA1:LLV(VOL,20);

31、成交量5日 10日量均线走平或多头向上

MAV5:=MA(V,5);MAV10:=MA(V,10);

XG:MAV5>MAV10 AND MAV5>=REF(MAV5,1) AND MAV10>=REF(MAV10,1) ANDCROSS(MAV5,MAV10);

32、5均量线大于10线均量线

A1:=MA(VOL,5);

A2:=MA(VOL,10);

XG:A1>=A2;

33、5.10.20日均线在最近5日内一直存在开盘价大于收盘价

MCO1:=(REF(MA(C,4),1)*4+O)/5;

MCO2:=(REF(MA(C,9),1)*9+O)/10;

MCO3:=(REF(MA(C,19),1)*19+O)/20;

MC1:=MA(C,5);

MC2:=MA(C,10);

MC3:=MA(C,20);

开盘价大:=MCO1>MC1 AND MCO2>MC2 AND MCO3>MC3 ;

一直存在:EVERY(开盘价大,5);

34、通达信30天以来最大成交量那天为阳K线的选股

var1:=close>open;

var2:=hhv(vol,30);

var3:=vol;

var4:=var2=var3;

var1 and var4zm:

35、个股最近3个K线周期内,出现成交量创此前120个K线周期内新低的情况。

zm:count(v=llv(v,120),3)>=1;

36、5.10.20日均线多头且当日涨幅大于百分之五选股公式

ma(c,5)>ma(c,10) and ma(c,10)>ma(c,20)andc>ref(c,1)*10.5; 

37、5.10.20日均线多头且成交量小于20万且当日涨幅大于百分之五选股公式

ma(c,5)>ma(c,10) and ma(c,10)>ma(c,20)and v<200000 andc>ref(c,1)*10.5; 

38、个股7天至15天出现两次涨停(出去ST的票) 

T1:=C>=REF(C,1)*1.095;

T2:=C=H;

T3:=T1&&T2;

T:SUM(T3,15)>=2;

39、个股7天至15天出现两次涨停

count(c/ref(c,1)>1.098,15) >=2;

40、通达信涨停双响炮选股公式

一次涨停至二次涨停之间的时间段内不破一次涨停最低价,一次与二次涨停时间间隔不超过30日。谢谢需要能识别选出30内有多次涨停的股票

TQ1:=C>=REF(C,1)*1.095 AND C>=H;

TQ:=BARSLAST(TQ1);

TG:=REF(L,(TQ));

TY:IF(L>=TG AND COUNT(TQ1,30)>=2 AND TQ<=30 ,1,0);

41、请看看我的选股公式怎么才能让他把ST的股票给剔除了!

VAR1:=EMA(EMA(CLOSE,9),9);

控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

AA:=IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0);

VAR2:=100*WINNER(CLOSE*0.95);

BB:=IF(VAR2>50 AND COST(85)0,控盘,0);

XG:AA AND BB;

VAR1:=EMA(EMA(CLOSE,9),9);

控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

AA:=IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0);

VAR2:=100*WINNER(CLOSE*0.95);

BB:=IF(VAR2>50 AND COST(85)0,控盘,0);

XG:=AA AND BB;

去除ST:=EXIST(C/REF(C,1)>1.055,60);

选股:XG AND 去除ST;

VAR1:=EMA(EMA(CLOSE,9),9);

控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

AA:=IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0);

VAR2:=100*WINNER(CLOSE*0.95);

BB:=IF(VAR2>50 AND COST(85)0,控盘,0);

CC:=IF(INBLOCK('ST板块'),0,1);

XG:AA AND BB AND CC;

42、最近90个交易日内曾经至少出现过二个涨停板的所有股票

count(c/ref(c,1)>=1.095 and c>=h,90)>=2;

43、在10个交易日内出现过先跌停后涨停的选股公式,跌停和涨停不需要连续出现

BARSLAST((C-REF(C,1))/REF(C,1)*100<-9.6)<=10 AND (C-REF(C,1))/REF(C,1)*100>9.6 AND

44、通达信的选股公式,在前期多少天内有涨停板的股票.

XG:SUM(C>REF(C,1)*1.0985,N)=M

N,M改成自己想要的数字,代表前N天有M个涨停

45、前50天内有过涨停和跌停的股票,注意是涨停和跌停都有的。

UPP:=C/REF(C,1)-1>0.098;

DOW:=1-C/REF(C,1)>0.098;

选股:COUNT(UPP,50)>=1 AND COUNT(DOW,50)>=1;

46、30个交易日内有三个或三个以上交易日连续涨停的选股公式

ZF:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=9.99/100;

LT:=ZF AND REF(ZF,1) AND REF(ZF,2);

EXIST(LT,30);

47、选出60个交易日内,个股k线图上出现涨停的个股!

count(c/ref(c,1)>1.1,60)>0;

48、涨停板后双阴选股公式

A1:=REF(C,2)>REF(C,3)*1.095;

A2:=C

A1 AND A2;​​​​

网站简介 | 免责声明 | 广告与合作 | 联系我们 | 意见建议 | 综合统计